WordPress plugin intelligence profile

Gauntlet Security

Performs a detailed security analysis of your WordPress installation. Provides specific instructions on how to make your site more secure.

WP PlugIndex snapshot

Current directory snapshot

Tested up to WordPress 4.6
Current version1.4.1
WordPress coverageTested up to WordPress 4.6
Minimum stackWP 3.4 · PHP —
Directory statusactive
Last directory update19 Jul 201610y ago
Active installations50Adoption metric — not a quality score
WordPress.org rating5.0 / 5 from 8 ratings
Official packageDirect from WordPress.org

Repository metrics are context, not quality scores. Active installations measure adoption and can strongly reflect a plugin’s age and historical popularity. Ratings, recent updates and “Tested up to” metadata also do not guarantee modern code, error-free operation, security, feature completeness or suitability for a particular site. Why active installs don’t tell the whole story →

WP PlugIndex currently records Gauntlet Security version 1.4.1 as active, updated 10y ago and tested up to WordPress 4.6.

Overview

About this plugin

Gauntlet Security can find opportunities for improving the security of your site. It checks many aspects of the site’s configuration including file permissions, server software, PHP, database, plugins, themes, and user accounts. The plugin will give each check a pass, warning, or fail and explain in clear language how you can fix the issue.

How you ultimately choose to patch these issues is up to you but whatever method you use, this plugin should always provide an accurate report. It does not make changes to your database or to any of your files and it should be compatible with all other security plugins.

Checks and recommendations include:

  • Set correct file and directory permissions
  • Turn off directory indexing
  • Prevent code execution in the uploads directory
  • Block files in the includes directory
  • Prevent access to stray files which could be useful to attackers
  • Keep PHP up-to-date
  • Disable dangerous PHP functions
  • Disable allow_url_include and allow_url_fopen PHP flags
  • Turn off the display of PHP errors
  • Don’t advertise the PHP version you are running
  • Use a strong database password
  • Change the default database table prefix
  • Keep WordPress up-to-date
  • Turn off file editing in the control panel
  • Set security keys in WP-Config file
  • Don’t advertise the WordPress version you are running
  • Turn off self-registration
  • Force SSL when accessing the admin area
  • Review the development activity and reputation of all plugins
  • Remove unused themes from the server
  • Rename the plugin directory
  • Move the active theme to an alternate location
  • Do not use TimThumb
  • Do not use common user names (such as “admin”)
  • Do not use weak passwords
  • Do not have a user with an ID = 1
  • Minimize the number of admin users
  • Users should not display their login usernames publicly
  • Prevent username enumeration through standard author URLs
  • …more tests planned

Check the screenshots for more detail on some of the above features.

org/Hardening_WordPress.

Disclaimer

php). Others require more in-depth changes to the filesystem or database. Before attempting any of these fixes, you should be comfortable experimenting and know how to undo any change you make.

That includes making backups and knowing how restore your site from those backups. I can’t guarantee that the recommendations or sample code provided in this plugin will not break your site or that they will prevent it from being hacked.

Requirements

  • Apache web server
  • WordPress 3.4 minimum
  • PHP 5.2.7 minimum
WordPress.org metadata

Plugin tags

Topics listed for this plugin in the WordPress.org directory.

  • exploit
  • hacks
  • secure
  • security
  • vulnerability
Compatibility & maintenance

Compatibility & maintenance

Tested up to WordPress 4.6

Not yet marked as tested with WordPress 7.1. WordPress.org currently lists Tested up to 4.6.

Current WordPress releaseWordPress 7.1
WordPress.org Tested up to4.6
Minimum requirementsWordPress 3.4 · PHP not listed
Update activity19 Jul 201610y ago

“Tested up to” is directory metadata supplied by the plugin author. WP PlugIndex does not turn an older declaration into a claim that the plugin is incompatible.

Changes recorded by WP PlugIndex

Recent tracked changes

No tracked version or compatibility changes have been recorded by WP PlugIndex yet.

Tracking & source

WP PlugIndex tracks public WordPress.org directory metadata and records selected version, compatibility and availability changes as they are detected.

Plugin watchlist

Watch this plugin

Sign in to your WP PlugIndex account or create a free account. Free accounts can watch up to 5 plugins and see what changed.

Watch limit

Watchlist limit reached

You have reached your current active watch limit.